home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-libs / timezone-data-2006a / timezone-data-2006a.ebuild < prev    next >
Text File  |  2006-04-25  |  1KB  |  41 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2006a.ebuild,v 1.6 2006/04/17 07:28:08 vapier Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
  8. HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
  9. SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${PV}.tar.gz
  10.     ftp://elsie.nci.nih.gov/pub/tzcode${PV}.tar.gz"
  11.  
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm ia64 ~m68k mips ppc ~ppc64 s390 ~sh sparc x86"
  15. IUSE=""
  16.  
  17. DEPEND=""
  18.  
  19. S=${WORKDIR}
  20.  
  21. src_unpack() {
  22.     unpack ${A}
  23.     cp Makefile{,.orig}
  24.     epatch "${FILESDIR}"/${PN}-2005n-makefile.patch
  25. }
  26.  
  27. src_install() {
  28.     make install DESTDIR="${D}" || die
  29.     rm -rf "${D}"/usr/share/zoneinfo-leaps
  30.     dodoc README Theory
  31.     dohtml *.htm *.jpg
  32. }
  33.  
  34. pkg_postinst() {
  35.     if [[ ! -e ${ROOT}/etc/localtime ]] ; then
  36.         ewarn "Please remember to set your timezone using the zic command."
  37.         rm -f "${ROOT}"/etc/localtime
  38.         ln -s ../usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
  39.     fi
  40. }
  41.